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Housing Innovations (HI) 
Section 508 Guide 

 
 
 
 

This document contains basic recommended 
guidelines for development of documents, PDF files 
and HTML pages.
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Introduction to Section 508 
 

Section 508 was made part of the Rehabilitation Act of 1973 in 1998. Its purpose is to 
“…require Federal agencies to make their electronic and information technology (EIT) 
accessible to people with disabilities.” 

 

What is 508 Compliance? 
 

508 Compliance is a web-based standard by which documents, video, multimedia, and 
websites are developed to allow equal access to information for all individuals with sensory 
impairments. Individuals with visual or hearing impairments can then use assistive 
technology software to interpret the content and provide either screen captions or have the 
content read out loud to the user. 

 

Purpose 
Section 508 requires that when any federal agencies and federal contractors develop, procure, 
maintain, or use electronic information technology, any person with a disability has access to 
and use of information, and data that is comparable to the access and use by federal employees 
who are not individuals with disabilities. 

 
How does this law impact Housing Innovations? 

• All federal agencies and federal contractors are required to ensure that their 
websites and the contents are compliant with Section 508 of the Act. 

• Video that appears on government websites must be captioned for the deaf and hard 
of hearing. 

• PDF documents and forms on government websites must be accessible to blind and low 
vision individuals, both government employees and the general public.
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Element Description Quick How To 
Bookmarks and 
Table of Contents 

Use Bookmarks or a Table of Contents (TOC) for 
documents over 9 pages. Create using Word’s 
Bookmark or TOC feature. Check that Bookmark 
or TOC entries hyperlink to the correct locations 
in the document. 

1. To create bookmarks, click 
“Insert” then “Bookmark.” 

2. To create a TOC, click 
“References” then “Table of 
Contents.” Select a TOC style. 

Bullets and 
Numbering 

Use the automatic list formats available in Word. 
Do not manually type lists preceded by special 
characters, such as hyphens or asterisks. 
Wingdings are not acceptable bullets. 

Click “Home” then the “Bullets,” 
“Numbering” or “Multilevel List” icon. 

Color Contrast Text must be easy to read in comparison to the 
background. Use very dark-colored lettering on 
a white or light-colored background. 

Test color contrast by printing in 
grayscale or by using one of the color 
contrast analyzer tools found online. 

Color Emphasis Do not use color for emphasis without providing 
an alternative method of emphasizing text (e.g., 
bold, italics, or both); do not use color alone. 

Example: Use the provider directory 
to find a list of doctors in your area. 

Comments and 
Tracked Changes 

Remove all comments from the text. Accept or 
reject tracked changes and turn off Track 
Changes. 

1. Right click on comment then 
select “Delete Comment.” 

2. Click “Review” then “Accept” or 
“Reject” changes. 

Flashing, Flickering, 
or Animated Text 

Do not use flashing, flickering, or animated text. -- 

Fonts Use recommended fonts: Times New Roman, 
Verdana, Arial, Tahoma, Helvetica, or Calibri. 

See “Style Elements” below. You can 
modify a style to change the font. 

Footnotes Create footnotes using the Footnotes linking tool. Click “References” then “Insert 
Footnote.” 

Page Breaks Use page breaks instead of hard returns to move 
text to the next page. 

Click “Insert” then “Page Break.” Or 
click “Page Layout” then “Breaks.” 

Page Numbering Use automatic page numbering fields. Click “Insert” then “Page Number.” 
Paragraph Spacing Use paragraph spacing instead of hard returns or 

tabs to increase spacing between paragraphs. 
Select one or more paragraphs. Click 
“Page Layout,” then under “Spacing,” 
adjust space “Before” and “After.” 

Print Preview View the document in Print Preview and check to 
see if it flows correctly from page to page. Look 
out for image placement, table format, and stray 
(“orphaned” or “widowed”) lines and characters. 

Click “File” then “Print.” A preview of 
the document automatically appears 
on the right-hand side of the screen. 

Style Elements Create a hierarchical structure using Word’s style 
formatting. Use Style elements (e.g., Heading 1, 
Heading 2) or a Multilevel List (e.g., Heading 1 to 
Heading 2 to Body Text). 

Click “Home” then select desired style 
from the “Styles” ribbon. Or click 
“Home” then the “Multilevel List” icon. 

URLs and E-mail 
Links 

All Web citations (URLs) and e-mail addresses 
must be correct, complete, and linked to an 
active Web or e-mail destination. 

Example: 
http://www.ctbos.org not 
www.ctbos.org 
Example: 
Jane.Doe@housinginnovations.us 

http://www.ctbos.org/
http://www.ctbos.org/
mailto:Jane.Doe@housinginnovations.us
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Document Layout and Formatting (above) 
Images 

Tables 

Element Description Quick How To 
Alternative Text 
(Alt Text) 

Provide alternative text descriptions (“alt text”) for 
all images, graphics, grouped images, and non- 
text elements that convey information. 
Do not provide alt text for images that are purely 
decorative. 

Right click on image. Select “Format 
Picture” then “Alt Text.” 

Background 
Images or 
Watermarks 

Do not use background images or watermarks. Click “Page Layout.” Select 
“Watermark” then “Remove 
Watermark.” 

Descriptive Text Provide descriptive text near a complex image 
such as a chart or graph. 

In a paragraph right above or below 
the image, describe the information 
the image is intending to convey. 

Grouping Images Individual images, objects, or graphics on a 
page that make up one combined graphic 
image must be grouped as one object. 

1. Click on each object one at a 
time. Select “Page Layout” then 
“Wrap Text.” Make sure that “In 
Line with Text” isn’t selected. 

2. Hold the Shift key and click on 
each object. 

3. Click “Group” then “Group” 
again. 

In-Line with Text Image layout must be set to “In Line with Text” 
for all images. 

Click on image. Next, click “Page 
Layout.” Select “Wrap Text” then “In 
Line with Text.” 

Text Boxes As a general rule, do not use text boxes for 
graphics or floating text. 

Exception: Text boxes are okay if 
the final format will be PDF or 
HTML. 

Element Description Quick How To 
Avoid Tabs or 
Spaces 

Do not use tabs or spaces to create a table-like 
structure. Instead, use Word’s table formatting. 

Click “Insert” then “Table.” 

Blank Cells Avoid blank cells. -- 
Descriptions and 
Labels 

All tables should be described and labeled. 
Exception: In some cases labeling a table may 
not be appropriate. For example, a small data 
table in a presentation may not need a label. 

Click “References” then “Insert 
Caption.” Insert a title or short 
description after the table number. 

Logical Reading 
Order 

Use a logical reading order from left to right, top 
to bottom. -- 

Merged Cells As a general rule, avoid merged cells. Exception: Merged cells are okay if 
the final format will be PDF or HTML. 

Row and Column 
Headers 

Provide a descriptive heading for each row and 
column in a data table, starting with the first left- 
hand column. 

 
-- 

Row Page Break In Table Properties, uncheck “Allow row to break 
across pages” (no matter if your table fits on one 
page or spans multiple pages). 

Right click within last table row on 
page. Select “Table Properties” then 
“Row.” Uncheck “Allow row to break 
across pages.” 

Table Header Row In Table Properties, check “Repeat as header row 
at the top of each page” (no matter if your table 
fits on one page or spans multiple pages). 

Right click within the top table row. 
Select “Table Properties” then “Row.” 
Check “Repeat as header rows.” 
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Simplified Table 
 

 
 
File Name 

 

Document Properties, Complex Content, and PDF Conversion 
Element Description Quick How To 

Complex Content If there is no other way to make the content 
accessible, provide a separate accessible 
version. 

Example: Organizational charts are 
often complex. Provide a separate 
full-text version that is 508-compliant. 

Converting to PDF 
(if you have Adobe 
Acrobat Professional) 

Convert documents to PDF by using the Acrobat 
add-in on your toolbar (preferred method) or by 
clicking “File,” “Save as Adobe PDF.” 
Do not use “Print,” “Printer,” “Adobe PDF.” 

If the Acrobat add-in on your toolbar 
doesn’t convert all of the formatting 
elements in your original document, 
try “File,” “Save as Adobe PDF.” 

Document 
Properties 

Fill out Title, Author, Subject (description), and 
Tags (keywords). 

Click “File,” “Info,” “Properties.” 
Choose item in “Properties” you wish 
to update. 

 
Web Content 

• All functionality must be operable by keyboard. 
• Valid HTML is key to making web sites accessible. 
• Pay special attention to the following elements: 

o Images 
o Forms 
o Data Tables 
o Frames 
o Navigational Elements 
o Dynamic Content/Interactivity 

 

Element Description Quick How To 
Be Concise The file name must be concise, clear, and 

generally no more than 30 characters in length. 
Example: 508HousingInnov-Ref.docx 

Spaces and 
Special Characters 

Do not use spaces or special characters in file 
names. Hyphens (-) are acceptable in file names. 

Example: CommonElements.docx or 
Common-Elements.docx 
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Fixing Inaccessible PDFs Using Adobe Acrobat Pro DC 
 
It is always best if possible to start with an accessible source document (e.g., in Microsoft Word) 
and export to an accessible PDF.  This way, if the document is edited later, the document’s 
accessibility features will still be intact and when the document is exported again to PDF the 
accessibility features will again be passed to the PDF. 
 
However, if the original source document is not available, accessibility features can be added to 
the PDF using Adobe Acrobat Pro DC. 
 
NOTE: Modifying PDFs can have unpredictable results, and there is no "Undo". Save often! 
(Saving multiple versions is recommended) 
 
Step 1. Does document have text? 
 
How to test: Try selecting text using a mouse, or select all text using Edit > "Select All" from 
the Acrobat menu. 
 
If No: This is an image file and is not accessible. Covert to text using View > Tools > 
"Recognize Text." 
 
Step 2. Is document tagged? 
 
How to test: Go to File Properties (Ctrl+D in Windows, Command+D in Mac). In the bottom 
left corner of the Document Properties dialog, see the "Tagged PDF" field. 
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If No, this document needs to be tagged. Tags provide the structure on which accessibility is 
built. Add tags by selecting View > Tools > Accessibility > "Add Tags To Document." 
 
Step 3. Does document need to be "touched up?" 
 
How to test: Use View > Tools > Accessibility > "Touch Up Reading Order" to see the order in 
which content on the current page will reflow if the document is viewed in a small window such 
as on a mobile device. This can also provide a fairly (though not entirely) accurate representation 
of the order in which screen readers will read the content. The page should be tagged in 
numerical order from top to bottom.  
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Some accessibility fixes can be made using this tool. Here are a few: 

• Hide decorative or redundant images from screen reader users. To do so, click an image, 
then click "background" 

• Add or edit alt text for informative images. To do so, right click on an image, then select 
"Edit alt text." 

• Rearrange read order if needed. To do so, click "Show order panel," then drag items to 
their appropriate location. 

• If the page includes data tables, click a table, then click the "Table Editor" button to edit 
accessibility features within the table. 

 



Handbook for Creating Section 508 Compliant Documents 

HI 508 
 

03/2020 
 

 

 

Step 4. Are headings marked up as headings at appropriate levels? 
 
How to test:  Study the document visually to determine what the heading structure should be. 
Keep in mind that headings should form an outline of the page. Next, open the Tags Panel by 
selecting View > Show/Hide > “Navigation Panes” > Tags. The Tags Panel shows a tree of tags. 
 

 
 
There are a variety of ways to explore the tag tree. For example, use Acrobat’s text selector tool 
to highlight text in the document (for example, a heading) then click the menu icon at the top of 
the Tags pane and choose "Find tag from selection." This will expand the tag tree if needed and 
highlight the selected tag. 
 
Alternatively, click the menu icon at the top of the Tags pane and be sure "Highlight Content" is 
checked. Then click on any tag to see the content associated with that tag highlighted in the 
document. 
 
Headings should be marked up with tags that are equivalent to HTML headings tags (i.e., <H1> 
for the main heading, <H2> for subheadings, then <H3>, <H4>, etc. Some authoring tools may 
create tags that have heading-like names (e.g., "<Heading_Level_1>"). However, these are not 
recognized by screen readers and will need to be changed. 
 
To change a tag, right click on the tag, select Properties, then choose an appropriate tag from the 
list. If you know the what the correct name should be for a particular tag, you can also double-
click the tag and type in the correct name. 
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Step 5. Does other markup need to be fixed? 
 
How to test: Follow the same instructions as in the previous step. However, rather than focusing 
specifically on headings, consider the overall structure. 
 

• Are lists tagged as lists? 
• Does content in appear in a reasonable order?  In Step 3 you checked the read order of 

content, and may have rearranged some items so they would flow in a meaningful order 
in a small window. While this order is typically close to the order of items in the tag tree, 
the latter is the actual order in which items will be read by screen readers. If items seem 
to be out of order in the tag tree, drag them to a better location. 

 
Authoring tools generate a wide variety of tags. These typically aren’t cause for alarm, as screen 
readers ignore most of them and render their content as paragraphs. As long as headings are 
tagged as headings; and lists, tables, and images are all tagged up appropriately, a document will 
likely be easy for screen reader users to navigate, read, and understand. 
 
In some cases, the tag tree of a document is a total mess, and it might be easier to delete all tags 
and start over building them from scratch rather than try to fix the existing tags. 
 
Step 6. Check for any lingering errors. 
 
How to test: Run the accessibility checker that is built in to Acrobat Pro.  Select Tools > 
Accessibility > "Full Check" then read the report and follow the prompts. 
 

 
 
The report lists items in various categories such as Document, Page Content, etc. Each item is 
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preceded by an icon indicating that the item passes, fails, or requires manual inspection. Right 
click on any item to see a list of options for fixing the problem or learning more about it. 
 
This is the final step in our checklist, rather than the first step, because some documents generate 
dozens of errors that can easily be addressed with the first five steps. This way, the accessibility 
checker will report fewer problems and will be easier to read and work with. 
 

How To Create a 508 Compliant Microsoft 
Word Document 
 
By using the built-in features within Microsoft Office, to include Word, you can avoid many of 
the most common mistakes related to accessibility. It is just as easy to build a 508 compliant 
document as it is to create a non-compliant one. In fact, using many of these built-in features 
makes creating a document much easier and faster. Follow the below guidelines and then visit 
the links on the right for more information and some video tutorials. The blue italicized items 
apply to all Microsoft Office Word, Excel and PowerPoint Documents.  

Best Practices and Most Common Issues related to 
Word Documents 
Style Headings 

DOs 
Use the built-in style headings to create a visual heading in your document. Styles can be 
found on the Home tab within the Styles panel.   

DON'Ts 
Do not manually create a heading by simply bolding or changing the font size or color. 

Visual Example 

 

Bulleted & Numbered Lists 
DOs 
Use the built-in list feature for bulleted and numbered lists. Lists can be found from the 
Home tab within the Paragraph panel. 

DON'Ts 
Do not create a list by typing the number at the beginning of every line or typing a 
hyphen as an example. 
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Visual Example 

 

Hyperlinks 
DOs 
Create hyperlinks using descriptive words for the hyperlink. Hyperlinks can be inserted 
from the Insert tab and then Hyperlink on the Links panel. Always double check that your 
hyperlinks work. 

DON'Ts 
Do not use "Click here" or "More" as hyperlinks. 
 
Visual Example 

 
 

Alt Text and Captions 
 

DOs 
Insert Alternative Text (Alt text) and captions for informational images and tables. For 
Images, right click on the image and choose Insert Caption.  Right click on the image and 
choose Format Picture and then, click the third icon over and click on ALT TEXT. For 
tables, right click on the table and choose Table Properties. The 5th tab is for ALT Text. 
 
DON'Ts 
Do not provide alt text or captions for non-informational or simply decorative images. 
When you run the accessibility checker this error should be ignored. The checker can 
only identify that the image does not have a tag. It does not know that it is a non-
informational image. For informational images, the text should convey the same message 
as the image. 
 
Visual Example 
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Multiple Images 
 
DOs 
If you have multiple images or objects that are layered over one another combine them 
into one image. You may be able to do this using the Group option or using a third-party 
tool such as SnagIt. 
 
DON'Ts 
Do not overlay or group several objects next to one another so they appear as one object. 

 
Color to Convey Meaning 

 
DOs 
When using color to convey meaning, add a non-color method as well such as text as 
shown in the visual example column. 
 
DON'Ts 
Do not use color alone to convey meaning. 

 
Visual Example 

  
 
 
 

 
 
 
 

Fonts 
 

 
Ready for 
Release 

1 No 

2 Yes 
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DOs 
Use fonts that are clear and legible (e.g., Arial or Times New Roman), generally in the 10 
to 14 point range. The spacing in the document should be enough to show paragraph 
breaks clearly. Spacing between lines should be at least 120% of the font size. This is the 
default in Word. 
 
DON'Ts 
Do not use fancy fonts that are more decorative than functional. This is especially 
important in headings. 

 
Table of Contents 
 

DOs 
Use the built-in Table of Contents feature to build a table of contents in a document. The 
Table of Contents feature is found on the Reference tab within the Table of Contents 
panel. 
DON'Ts 
Do not type a table of contents manually. 

 
Visual Example 

 
 

Tables 
 

DOs 
Only use tables to represent tabular information. Ensure that there are row and column 
headings and do not merge cells. 
 
DON'Ts 
Do not use a table for aligning text or non-tabular data. Do not merge cells. 

 
Comments and Track Changes 
 

DOs 
Finalize your document by removing all comments and accepting or rejecting track 
changes. Under the Review tab, ensure you are seeing all markup and that none display in 
the document. 
 
DON'Ts 
Do not have comments, annotations, or tracked changes within your final document. 
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Visual Example 

 
 

Color Contrasts 
 

DOs 
Use a strong color contrast between text and backgrounds. Black and white is always a 
good choice. This is not usually checked via Microsoft applications. It requires a visual 
check. 
 
DON'Ts 
Some examples for Don'ts: Do not use white text on a light gray background. Do not use 
red and green text and highlighting together. Do not use red text on a black background. 

 
 

Accessibility Checker 
 

DOs 
Always run the accessibility checker when you are finished with your document to see if 
any issues are identified, then remediate those items prior to publishing your document. 
You access the checker by clicking File, the Info menu option will display and then select 
Check for Issues drop down and select Check Accessibility. 
 
DON'Ts 
Don't assume your document is good, always run the checker as a double check. 
 
Visual Example 
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MS Office Accessibility Checker - 
Understand the inspection results 
After Accessibility Checker inspects your content, it reports the inspection results based on the 
severity of the issue found, categorized as follows: 

• Errors. Issues that are reported as errors include content that is very difficult or 
impossible for people with disabilities to understand. 

• Warnings. Warnings, in many cases, mean that the content is challenging for people with 
disabilities to understand. 

• Tips. Tips let you know that, even though people with disabilities can understand the 
content, it could be better organized or presented to improve their experience. 

Reference Sites for Section 508 
(Information Technology) 
Creating Section 508 Compliant Electronic Documents 
This training provides step-by-step instructions on creating Section 508 compliant electronic 
documents. 

PDF File 508 Checklist (WCAG 2.0 Refresh) 

https://www.doi.gov/ocio/508compliancetraining
https://www.doi.gov/ocio/508compliancetraining
https://www.hhs.gov/web/section-508/making-files-accessible/checklist/pdf/index.html
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Accessibility Basics 

 

https://www.usability.gov/what-and-why/accessibility.html
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